Cisco EIGRP + OpenBSD eigrpd

I was unable to progress much further with getting gns3server running on FreeBSD so I have given up (for now).

In the meantime I have configure my GNS3 gui to run everything on a remote server (a VirtualBox GNS3 server on Linux).

Screenshot_2017-09-09_14-13-51

Getting OpenBSD to work with Cisco Routers with EIGRP is pretty straight forward. There are only 5 files that need to be modified:

Screenshot_2017-09-09_14-15-15

Cisco configuration is rather simple as well (for example R1):
interface FastEthernet0/0
ip address 10.0.0.2 255.255.255.252
duplex half
!
interface GigabitEthernet1/0
ip address 10.0.0.5 255.255.255.252
negotiation auto
!
interface GigabitEthernet2/0
ip address 10.0.0.9 255.255.255.252
negotiation auto
!
router eigrp 1
network 10.0.0.0 0.0.0.3
network 10.0.0.4 0.0.0.3
network 10.0.0.8 0.0.0.3
auto-summary
eigrp router-id 1.1.1.1
!
Here is the subnetting info for all interfaces:

OBRP: e0/0 DHCP
e0/1 10.0.0.1/30

R1: f0/0 10.0.0.2/30
g1/0 10.0.0.5/30
g2/0 10.0.0.9/30

R2: g1/0 10.0.0.6/30
g2/0 10.0.0.13/30

R3: g1/0 10.0.0.10/30
g2/0 10.0.0.17/30

R4: g1/0 10.0.0.14/30
g2/0 10.0.0.18/30
f0/0 172.16.0.100

VPC1: 172.16.0.1/24

Here are some “show” commands on the Cisco routers and via “eigrpctl” command:

Screenshot_2017-09-09_14-17-49

Screenshot_2017-09-09_14-16-19

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s