3.14 Troubleshoot basic Layer 3 end-to-end connectivity issues

The following commands are used to troubleshoot basic IP (L3) connectivity issues:

  1. ping
  2. traceroute
  3. “show”  commands

The ping commands which stands for packet internet groper. It sends raw ICMP packets and is the most common use or testing links as it tests traffic it both directions.

The various trace route commands show the hops that a IP packet takes on route to it’s destination.

“show” commands such as “show ip route” on IOS or “route show” on FreeBSD are useful for finding L3 problems due to incorrectly configured or missing routes.

If you follow the examples in this blog you will have to use these commands during the exercises naturally. I think it is pointless to go through the commands without a context.

3.13 Configure, verify, and troubleshoot RIPv2 for IPv4 (excluding authentication, filtering, manual summarization, redistribution)

Configuring RIP is very simple. The following commands configure RIP v2 and RIP for each network:

Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#no auto-summary
Router(config-router)#network 192.168.2.0

There is only two “show” commands for RIP:

Router#show ip rip database 
192.168.0.0/24 auto-summary
192.168.0.0/24 directly connected, FastEthernet0/0
192.168.1.0/24 auto-summary
192.168.1.0/24
 [1] via 192.168.0.3, 00:00:09, FastEthernet0/0
192.168.2.0/24 auto-summary
192.168.2.0/24 directly connected, GigabitEthernet4/0
192.168.3.0/24 auto-summary
192.168.3.0/24
 [1] via 192.168.2.2, 00:00:19, GigabitEthernet4/0
Router#

Routing Protocol is "rip"
 Outgoing update filter list for all interfaces is not set
 Incoming update filter list for all interfaces is not set
 Sending updates every 30 seconds, next due in 29 seconds
 Invalid after 180 seconds, hold down 180, flushed after 240
 Redistributing: rip
 Default version control: send version 2, receive version 2
 Interface Send Recv Triggered RIP Key-chain
 FastEthernet0/0 2 2 
 GigabitEthernet4/0 2 2 
 Automatic network summarization is not in effect
 Maximum path: 4
 Routing for Networks:
 192.168.0.0
 192.168.2.0
 Routing Information Sources:
 Gateway Distance Last Update
 192.168.2.2 120 00:00:38
 192.168.0.3 120 00:00:31
 Distance: (default is 120)

To verify RIP check the routing table:

Router#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.0.0/24 is directly connected, FastEthernet0/0
R 192.168.1.0/24 [120/1] via 192.168.0.3, 00:00:24, FastEthernet0/0
C 192.168.2.0/24 is directly connected, GigabitEthernet4/0
R 192.168.3.0/24 [120/1] via 192.168.2.2, 00:00:05, GigabitEthernet4/0
Router#

If routes are missing this could mean:

  1. missing network command(s)
  2. interface or neighbor down
  3. mismatched RIP version
  4. ACLs blocking updates
    1. RIP v2 uses the 224.0.0.9 multicast address

To troubleshoot RIPv2 use the debug commands:

Router#debug ip rip events 
RIP event debugging is on
Router#debug ip rip database 
RIP database events debugging is on
Router#
*Apr 21 16:02:04.807: RIP: sending v2 update to 224.0.0.9 via GigabitEthernet4/0 (192.168.2.1)
*Apr 21 16:02:04.807: RIP: Update contains 2 routes
*Apr 21 16:02:04.807: RIP: Update queued
*Apr 21 16:02:04.811: RIP: Update sent via GigabitEthernet4/0
*Apr 21 16:02:13.907: RIP: received v2 update from 192.168.2.2 on GigabitEthernet4/0
*Apr 21 16:02:13.907: RIP-DB: network_update with 192.168.3.0/24 succeeds
*Apr 21 16:02:13.911: RIP-DB: adding 192.168.3.0/24 (metric 1) via 192.168.2.2 on GigabitEthernet4/0 to RIP database
*Apr 21 16:02:13.911: RIP: Update contains 1 routes
*Apr 21 16:02:15.775: RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0 (192.168.0.1)
*Apr 21 16:02:15.775: RIP: Update contains 2 routes
*Apr 21 16:02:15.775: RIP: Update queued
*Apr 21 16:02:15.779: RIP: Update sent via FastEthernet0/0
*Apr 21 16:02:17.587: RIP: received v2 update from 192.168.0.3 on FastEthernet0/0
*Apr 21 16:02:17.587: RIP-DB: network_update with 192.168.1.0/24 succeeds
*Apr 21 16:02:17.591: RIP-DB: adding 192.168.1.0/24 (metric 1) via 192.168.0.3 on FastEthernet0/0 to RIP database

3.12 Configure, verify, and troubleshoot EIGRP for IPv6 (excluding authentication, filtering, manual summarization, redistribution, stub)

Begin with this topology:

Screenshot_2018-04-21_16-59-57

First enable IPv6 routing, configure a router id (optional) and enable the EIGRP process:

Router(config)#ipv6 unicast-routing 
Router(config)#ipv6 router eigrp 1
Router(config-rtr)#eigrp router-id 1.1.1.1
Router(config-rtr)#no shutdown

 

Next configure EIGRP on each interface:

Router(config)#int g0/0
Router(config-if)#ipv6 address 2001:db8:0:0::/64 eui-64 
Router(config-if)#ipv6 eigrp 1
Router(config-if)#no shutdown

The show commands are similar but use “ipv6” instead:

Router#show ipv6 int brief
Ethernet0/0 [administratively down/down]
 unassigned
GigabitEthernet0/0 [up/up]
 FE80::C801:17FF:FE26:8
 2001:DB8::C801:17FF:FE26:8
GigabitEthernet1/0 [up/up]
 FE80::C801:17FF:FE26:1C
 2001:DB8:0:3:C801:17FF:FE26:1C
GigabitEthernet2/0 [administratively down/down]
 unassigned
GigabitEthernet3/0 [administratively down/down]
 unassigned
Router#show ipv6 eigrp 1 interfaces 
IPv6-EIGRP interfaces for process 1
 Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Gi0/0 1 0/0 657 0/1 3272 0
Gi1/0 1 0/0 1029 0/1 6396 0
Router#show ipv6 eigrp 1 nhe 
Router#show ipv6 eigrp 1 ne 
Router#show ipv6 eigrp 1 neighbors 
IPv6-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
 (sec) (ms) Cnt Num
1 Link-local address: Gi1/0 14 00:00:18 1029 5000 0 9
 FE80::C803:17FF:FE44:1C
0 Link-local address: Gi0/0 11 00:11:30 657 3942 0 10
 FE80::C802:17FF:FE35:8
Router#show ipv6 eigrp 1 topo 
Router#show ipv6 eigrp 1 topology 
IPv6-EIGRP Topology Table for AS(1)/ID(1.1.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
 r - reply Status, s - sia Status

P 2001:DB8:0:1::/64, 2 successors, FD is 3072
 via FE80::C802:17FF:FE35:8 (3072/2816), GigabitEthernet0/0
 via FE80::C803:17FF:FE44:1C (3072/2816), GigabitEthernet1/0
P 2001:DB8::/64, 1 successors, FD is 2816
 via Connected, GigabitEthernet0/0
P 2001:DB8:0:3::/64, 1 successors, FD is 2816
 via Connected, GigabitEthernet1/0
Router#show ipv6 eigrp 1 ?
 interfaces EIGRP interfaces
 neighbors EIGRP neighbors
 topology EIGRP Topology Table
 traffic EIGRP Traffic Statistics

Router#show ipv6 route
IPv6 Routing Table - Default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
 B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
 I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
 D - EIGRP, EX - EIGRP external
 O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
 ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
C 2001:DB8::/64 [0/0]
 via GigabitEthernet0/0, directly connected
L 2001:DB8::C801:17FF:FE26:8/128 [0/0]
 via GigabitEthernet0/0, receive
D 2001:DB8:0:1::/64 [90/3072]
 via FE80::C802:17FF:FE35:8, GigabitEthernet0/0
 via FE80::C803:17FF:FE44:1C, GigabitEthernet1/0
C 2001:DB8:0:3::/64 [0/0]
 via GigabitEthernet1/0, directly connected
L 2001:DB8:0:3:C801:17FF:FE26:1C/128 [0/0]
 via GigabitEthernet1/0, receive
L FF00::/8 [0/0]
 via Null0, receive
Router#

Use similar debug commands to diagnose issues with EIGRP for IPv6:

Router#debug ipv6 eigrp 
IP-EIGRP Route Events debugging is on
Router#
*Apr 21 17:42:10.127: IPv6-EIGRP(0:1): Processing incoming UPDATE packet
*Apr 21 17:42:10.859: IPv6-EIGRP(0:1): Processing incoming UPDATE packet
*Apr 21 17:42:10.859: IPv6-EIGRP(0:1): Int 2001:DB8:0:1::/64 M 3072 - 2560 512 SM 2816 - 2560 256
*Apr 21 17:42:10.859: IPv6-EIGRP(0:1): 2001:DB8:0:1::/64 (90/3072) added to RIB
*Apr 21 17:42:10.859: IPv6-EIGRP(0:1): 2001:DB8:0:1::/64 (90/3072) added to RIB
*Apr 21 17:42:10.859: IPv6-EIGRP(0:1): Int 2001:DB8:0:3::/64 M 3072 - 2560 512 SM 2816 - 2560 256
*Apr 21 17:42:10.859: IPv6-EIGRP(0:1): 2001:DB8:0:3::/64 routing table not updated
*Apr 21 17:42:10.859: IPv6-EIGRP(0:1): Int 2001:DB8::/64 M 3328 - 2560 768 SM 3072 - 2560 512
*Apr 21 17:42:10.859: IPv6-EIGRP(0:1): 2001:DB8::/64 routing table not updated
*Apr 21 17:42:10.859: IPv6-EIGRP(0:1): 2001:DB8::/64 routing table not updated
*Apr 21 17:42:10.871: IPv6-EIGRP(0:1): 2001:DB8::/64 - do advertise out GigabitEthernet1/0
*Apr 21 17:42:10.871: IPv6-EIGRP(0:1): Int 2001:DB8::/64 metric 2816 - 2560 256
*Apr 21 17:42:10.871: IPv6-EIGRP(0:1): 2001:DB8:0:3::/64 - do advertise out GigabitEthernet1/0
*Apr 21 17:42:10.871: IPv6-EIGRP(0:1): Int 2001:DB8:0:3::/64 metric 2816 - 2560 256
*Apr 21 17:42:10.875: IPv6-EIGRP(0:1): Int 2001:DB8:0:1::/64 metric 3072 - 2560 512
*Apr 21 17:42:10.879: IPv6-EIGRP(0:1): Processing incoming UPDATE packet
*Apr 21 17:42:10.879: IPv6-EIGRP(0:1): Int 2001:DB8:0:1::/64 M 3072 - 2560 512 SM 2816 - 2560 256
*Apr 21 17:42:10.879: IPv6-EIGRP(0:1): Int 2001:DB8:0:3::/64 M 3072 - 2560 512 SM 2816 - 2560 256
*Apr 21 17:42:10.879: IPv6-EIGRP(0:1): Int 2001:DB8::/64 M 3328 - 2560 768 SM 3072 - 2560 512
*Apr 21 17:42:10.891: IPv6-EIGRP(0:1): Processing incoming UPDATE packet
*Apr 21 17:42:10.891: IPv6-EIGRP(0:1): Int 2001:DB8::/64 M 4294967295 - 2560 4294967295 SM 4294967295 - 2560 4294967295
*Apr 21 17:42:10.891: IPv6-EIGRP(0:1): 2001:DB8::/64 routing table not updated
*Apr 21 17:42:10.899: IPv6-EIGRP(0:1): Int 2001:DB8:0:1::/64 metric 3072 - 2560 512
*Apr 21 17:42:10.975: IPv6-EIGRP(0:1): 2001:DB8::/64 - do advertise out GigabitEthernet1/0
*Apr 21 17:42:10.975: IPv6-EIGRP(0:1): Int 2001:DB8::/64 metric 2816 - 2560 256
*Apr 21 17:42:10.975: IPv6-EIGRP(0:1): 2001:DB8:0:3::/64 - do advertise out GigabitEthernet1/0
*Apr 21 17:42:10.979: IPv6-EIGRP(0:1): Int 2001:DB8:0:3::/64 metric 2816 - 2560 256

3.11 Configure, verify, and troubleshoot EIGRP for IPv4 (excluding authentication, filtering, manual summarization, redistribution, stub)

Screenshot_2018-04-08_17-17-37.png

For the above topology the configuration is rather simple. In order for the routers to form neighbor relationships they must have the same EIGRP process id:

R1 config:

interface FastEthernet0/0
 ip address 10.1.1.1 255.255.255.0
 duplex half
!
interface GigabitEthernet4/0
 ip address 10.0.0.1 255.255.255.0
 negotiation auto
!
router eigrp 1
 network 10.0.0.0 0.0.0.255
 network 10.1.1.0 0.0.0.255
 auto-summary
!

R2 config:

interface GigabitEthernet4/0
 ip address 10.0.0.2 255.255.255.0
 negotiation auto
!
interface GigabitEthernet5/0
 ip address 10.2.2.2 255.255.255.0
 negotiation auto
!
interface GigabitEthernet6/0
 no ip address
 shutdown
 negotiation auto
!
router eigrp 1
 network 10.0.0.0 0.0.0.255
 network 10.2.2.0 0.0.0.255
 auto-summary
!

R3 config:

interface FastEthernet0/0
 ip address 10.1.1.3 255.255.255.0
 duplex half
!
interface GigabitEthernet4/0
 ip address 10.2.2.3 255.255.255.0
 negotiation auto
!
router eigrp 1
 network 10.1.1.0 0.0.0.255
 network 10.2.2.0 0.0.0.255
 auto-summary
!

Troubleshooting EIGRP is rather simple use the following commands:

R1#show ip eigrp neighbors 
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
 (sec) (ms) Cnt Num
1 10.1.1.3 Fa0/0 12 00:00:34 37 222 0 10
0 10.0.0.2 Gi4/0 14 00:04:59 15 300 0 8
R1#show ip eigrp ? 
 <1-65535> Autonomous System
 accounting IP-EIGRP Accounting
 interfaces IP-EIGRP interfaces
 neighbors IP-EIGRP neighbors
 topology IP-EIGRP Topology Table
 traffic IP-EIGRP Traffic Statistics
 vrf Select a VPN Routing/Forwarding instance

R1#show ip eigrp interfaces 
IP-EIGRP interfaces for process 1
 Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Gi4/0 1 0/0 15 0/1 50 0
Fa0/0 1 0/0 37 0/1 50 0
R1#show ip eigrp topology 
IP-EIGRP Topology Table for AS(1)/ID(10.1.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
 r - reply Status, s - sia Status

P 10.2.2.0/24, 1 successors, FD is 3072
 via 10.0.0.2 (3072/2816), GigabitEthernet4/0
 via 10.1.1.3 (28416/2816), FastEthernet0/0
P 10.1.1.0/24, 1 successors, FD is 28160
 via Connected, FastEthernet0/0
P 10.0.0.0/24, 1 successors, FD is 2816
 via Connected, GigabitEthernet4/0
R1#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 3 subnets
D 10.2.2.0 [90/3072] via 10.0.0.2, 00:00:41, GigabitEthernet4/0
C 10.1.1.0 is directly connected, FastEthernet0/0
C 10.0.0.0 is directly connected, GigabitEthernet4/0

Missing routes in the routing table may indicate a failed relationship or missing “network” commands in the EIGRP configuration.

The debug commands are helpful for troubleshooting neighbor relationships:

 
R3#debug ip eigrp                    
IP-EIGRP Route Events debugging is on
R3#debug ip eigrp nei
R3#debug ip eigrp neighbor 1 10.1.1.1
IP Neighbor target enabled on AS 1 for 10.1.1.1
IP-EIGRP Neighbor Target Events debugging is on

R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#int g4/0
R3(config-if)#shutdown
*Apr  8 17:42:34.219: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.2.2.2 (GigabitEthernet4/0) is down: interface down
*Apr  8 17:42:34.223: IP-EIGRP(Default-IP-Routing-Table:1): route installed for 10.0.0.0  ()
*Apr  8 17:42:34.247: IP-EIGRP(Default-IP-Routing-Table:1): 10.2.2.0/24 - not in IP routing table
*Apr  8 17:42:34.247: IP-EIGRP(Default-IP-Routing-Table:1): Int 10.2.2.0/24 metric 4294967295 - 0 4294967295
*Apr  8 17:42:34.283: IP-EIGRP(Default-IP-Routing-Table:1): Processing incoming REPLY packet
*Apr  8 17:42:34.283: IP-EIGRP(Default-IP-Routing-Table:1): Int 10.2.2.0/24 M 28672 - 25600 3072 SM 3072 - 2560 512
*Apr  8 17:42:34.287: IP-EIGRP(Default-IP-Routing-Table:1): route installed for 10.2.2.0  ()
R3(config-if)#no shutdown
*Apr  8 17:42:36.163: %LINK-5-CHANGED: Interface GigabitEthernet4/0, changed state to administratively down
*Apr  8 17:42:36.327: IP-EIGRP(Default-IP-Routing-Table:1): 10.2.2.0/24 - do advertise out FastEthernet0/0
*Apr  8 17:42:36.327: IP-EIGRP(Default-IP-Routing-Table:1): Int 10.2.2.0/24 metric 4294967295 - 25600 4294967295
*Apr  8 17:42:36.387: IP-EIGRP(Default-IP-Routing-Table:1): Processing incoming REPLY packet
*Apr  8 17:42:36.387: IP-EIGRP(Default-IP-Routing-Table:1): Int 10.2.2.0/24 M 28672 - 25600 3072 SM 3072 - 2560 512
*Apr  8 17:42:36.387: IP-EIGRP(Default-IP-Routing-Table:1): 10.2.2.0/24 routing table not updated thru 10.1.1.1
*Apr  8 17:42:36.403: IP-EIGRP(Default-IP-Routing-Table:1): 10.2.2.0/24 - do advertise out FastEthernet0/0
*Apr  8 17:42:36.403: IP-EIGRP(Default-IP-Routing-Table:1): Int 10.2.2.0/24 metric 2816 - 2560 256
*Apr  8 17:42:37.159: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.2.2.2 (GigabitEthernet4/0) is up: new adjacency
*Apr  8 17:42:37.179: IP-EIGRP(Default-IP-Routing-Table:1): 10.1.1.0/24 - do advertise out GigabitEthernet4/0
*Apr  8 17:42:37.179: IP-EIGRP(Default-IP-Routing-Table:1): Int 10.1.1.0/24 metric 28160 - 25600 2560
*Apr  8 17:42:37.183: IP-EIGRP(Default-IP-Routing-Table:1): 10.0.0.0/24 - do advertise out GigabitEthernet4/0
*Apr  8 17:42:37.183: IP-EIGRP(Default-IP-Routing-Table:1): Int 10.0.0.0/24 metric 28416 - 25600 2816
*Apr  8 17:42:37.183: IP-EIGRP(Default-IP-Routing-Table:1): 10.2.2.0/24 - do advertise out GigabitEthernet4/0
*Apr  8 17:42:38.267: %LINK-3-UPDOWN: Interface GigabitEthernet4/0, changed state to up
*Apr  8 17:42:42.011: IP-EIGRP(Default-IP-Routing-Table:1): Processing incoming UPDATE packet
*Apr  8 17:42:42.215: IP-EIGRP(Default-IP-Routing-Table:1): Processing incoming UPDATE packet
*Apr  8 17:42:42.215: IP-EIGRP(Default-IP-Routing-Table:1): Int 10.0.0.0/24 M 3072 - 2560 512 SM 2816 - 2560 256
*Apr  8 17:42:42.219: IP-EIGRP(Default-IP-Routing-Table:1): route installed for 10.0.0.0  ()
*Apr  8 17:42:42.219: IP-EIGRP(Default-IP-Routing-Table:1): route installed for 10.0.0.0  ()
*Apr  8 17:42:42.219: IP-EIGRP(Default-IP-Routing-Table:1): Int 10.1.1.0/24 M 28672 - 25600 3072 SM 28416 - 25600 2816
*Apr  8 17:42:42.219: IP-EIGRP(Default-IP-Routing-Table:1): 10.1.1.0/24 routing table not updated thru 10.2.2.2
*Apr  8 17:42:42.219: IP-EIGRP(Default-IP-Routing-Table:1): 10.1.1.0/24 - do advertise out GigabitEthernet4/0
*Apr  8 17:42:42.219: IP-EIGRP(Default-IP-Routing-Table:1): Int 10.1.1.0/24 metric 28160 - 25600 2560
*Apr  8 17:42:42.219: IP-EIGRP(Default-IP-Routing-Table:1): 10.2.2.0/24 - do advertise out GigabitEthernet4/0
*Apr  8 17:42:42.227: IP-EIGRP(Default-IP-Routing-Table:1): Processing incoming UPDATE packet
*Apr  8 17:42:42.227: IP-EIGRP(Default-IP-Routing-Table:1): Int 10.0.0.0/24 M 3072 - 2560 512 SM 2816 - 2560 256
*Apr  8 17:42:42.227: IP-EIGRP(Default-IP-Routing-Table:1): Int 10.1.1.0/24 M 28672 - 25600 3072 SM 28416 - 25600 2816
*Apr  8 17:42:42.231: IP-EIGRP(Default-IP-Routing-Table:1): Int 10.0.0.0/24 metric 3072 - 2560 512
*Apr  8 17:42:42.235: IP-EIGRP(Default-IP-Routing-Table:1): Processing incoming UPDATE packet
*Apr  8 17:42:42.235: IP-EIGRP(Default-IP-Routing-Table:1): Int 10.1.1.0/24 M 4294967295 - 25600 4294967295 SM 4294967295 - 25600 4294967295
*Apr  8 17:42:42.235: IP-EIGRP(Default-IP-Routing-Table:1): 10.0.0.0/24 - do advertise out FastEthernet0/0
*Apr  8 17:42:42.239: IP-EIGRP(Default-IP-Routing-Table:1): Int 10.0.0.0/24 metric 3072 - 2560 512
*Apr  8 17:42:42.247: IP-EIGRP(Default-IP-Routing-Table:1): 10.1.1.0/24 #- do advertise out GigabitEthernet4/0
*Apr  8 17:42:42.247: IP-EIGRP(Default-IP-Routing-Table:1): Int 10.1.1.0/24 metric 28160 - 25600 2560
*Apr  8 17:42:42.247: IP-EIGRP(Default-IP-Routing-Table:1): 10.2.2.0/24 - do advertise out GigabitEthernet4/0

 

3.10 Configure, verify, and troubleshoot single area and multi-area OSPFv3 for IPv6 (excluding authentication, filtering, manual summarization, redistribution, stub, virtual-link, and LSAs)

Starting with the following network:

Screenshot_2018-04-21_16-23-59.png

Configuring OSPFv3 for IPv6 is very similar to the IPv4 configuration:

First configure a router ID and enable IPv6 routing:

Router(config)ipv6 unicast-routing
Router(config)#ipv6 router ospf 1 
Router(config-rtr)#router-id 1.1.1.1

Building configuration…

Configure interfaces and enable OSPFv3 on each interface:

Router(config-if)#ipv6 address 2001:db8:0:3::/64 eui-64 
Router(config-if)#ipv6 ospf 1 area 0
Router(config-if)#no shutdown

Use the same “show” commands. Except use “ipv6” instead of “ip”.

Router#show ipv6 route
IPv6 Routing Table - Default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
 B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
 I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
 D - EIGRP, EX - EIGRP external
 O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
 ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
C 2001:DB8:0:1::/64 [0/0]
 via GigabitEthernet0/0, directly connected
L 2001:DB8:0:1:C801:16FF:FE67:8/128 [0/0]
 via GigabitEthernet0/0, receive
O 2001:DB8:0:2::/64 [110/2]
 via FE80::C802:16FF:FE76:8, GigabitEthernet0/0
 via FE80::C803:16FF:FE85:1C, GigabitEthernet1/0
C 2001:DB8:0:3::/64 [0/0]
 via GigabitEthernet1/0, directly connected
L 2001:DB8:0:3:C801:16FF:FE67:1C/128 [0/0]
 via GigabitEthernet1/0, receive
L FF00::/8 [0/0]
 via Null0, receive
Router#show ipv6 protocols
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "ospf 1"
 Interfaces (Area 0):
 GigabitEthernet1/0
 GigabitEthernet0/0
 Redistribution:
 None
Router#show ipv6 ospf 
 Routing Process "ospfv3 1" with ID 1.1.1.1
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Number of external LSA 0. Checksum Sum 0x000000
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 Reference bandwidth unit is 100 mbps
 Area BACKBONE(0)
 Number of interfaces in this area is 2
 SPF algorithm executed 3 times
 Number of LSA 13. Checksum Sum 0x08DDED
 Number of DCbitless LSA 0
 Number of indication LSA 0
 Number of DoNotAge LSA 0
 Flood list length 0

Router#

To debug OSPFv3 use similar debug commands:

Router#debug ipv6 ospf e
Router#debug ipv6 ospf events 
 OSPFv3 events debugging is on
Router#debug ipv6 ospf adj 
 OSPFv3 adjacency events debugging is on
Router#
*Apr 21 17:02:23.835: Insert LSA 5 adv_rtr 2.2.2.2, type 0x2002 in maxage
*Apr 21 17:02:23.835: Insert LSA 5120 adv_rtr 2.2.2.2, type 0x2009 in maxage
*Apr 21 17:02:27.239: OSPFv3: Cannot see ourself in hello from 2.2.2.2 on GigabitEthernet0/0, state INIT
*Apr 21 17:02:27.243: OSPFv3: Neighbor change Event on interface GigabitEthernet0/0
*Apr 21 17:02:27.243: OSPFv3: DR/BDR election on GigabitEthernet0/0 
*Apr 21 17:02:27.243: OSPFv3: Elect BDR 1.1.1.1
*Apr 21 17:02:27.247: OSPFv3: Elect DR 1.1.1.1
*Apr 21 17:02:27.247: OSPFv3: Elect BDR 0.0.0.0
*Apr 21 17:02:27.247: OSPFv3: Elect DR 1.1.1.1
*Apr 21 17:02:27.247: DR: 1.1.1.1 (Id) BDR: none 
*Apr 21 17:02:27.247: OSPFv3: Remember old DR 2.2.2.2 (id)
*Apr 21 17:02:27.271: OSPFv3: 2 Way Communication to 2.2.2.2 on GigabitEthernet0/0, state 2WAY
*Apr 21 17:02:27.275: OSPFv3: Neighbor change Event on interface GigabitEthernet0/0
*Apr 21 17:02:27.275: OSPFv3: DR/BDR election on GigabitEthernet0/0 
*Apr 21 17:02:27.275: OSPFv3: Elect BDR 2.2.2.2
*Apr 21 17:02:27.275: OSPFv3: Elect DR 1.1.1.1
*Apr 21 17:02:27.275: DR: 1.1.1.1 (Id) BDR: 2.2.2.2 (Id)
*Apr 21 17:02:27.275: OSPFv3: GigabitEthernet0/0 Nbr 2.2.2.2: Prepare dbase exchange
*Apr 21 17:02:27.275: OSPFv3: Send DBD to 2.2.2.2 on GigabitEthernet0/0 seq 0x7A7 opt 0x0013 flag 0x7 len 28
*Apr 21 17:02:32.075: OSPFv3: Send DBD to 2.2.2.2 on GigabitEthernet0/0 seq 0x7A7 opt 0x0013 flag 0x7 len 28
*Apr 21 17:02:32.075: OSPFv3: Retransmitting DBD to 2.2.2.2 on GigabitEthernet0/0 [1]
*Apr 21 17:02:32.263: OSPFv3: Rcv DBD from 2.2.2.2 on GigabitEthernet0/0 seq 0xD64 opt 0x0013 flag 0x7 len 28 mtu 1500 state EXSTART
*Apr 21 17:02:32.267: OSPFv3: NBR Negotiation Done. We are the SLAVE
*Apr 21 17:02:32.267: OSPFv3: GigabitEthernet0/0 Nbr 2.2.2.2: Summary list built, size 11
*Apr 21 17:02:32.267: OSPFv3: Send DBD to 2.2.2.2 on GigabitEthernet0/0 seq 0xD64 opt 0x0013 flag 0x2 len 248
*Apr 21 17:02:32.279: OSPFv3: Rcv DBD from 2.2.2.2 on GigabitEthernet0/0 seq 0xD65 opt 0x0013 flag 0x1 len 248 mtu 1500 state EXCHANGE
*Apr 21 17:02:32.283: OSPFv3: Exchange Done with 2.2.2.2 on GigabitEthernet0/0
*Apr 21 17:02:32.283: OSPFv3: Send LS REQ to 2.2.2.2 length 12 LSA count 1
*Apr 21 17:02:32.283: OSPFv3: Send DBD to 2.2.2.2 on GigabitEthernet0/0 seq 0xD65 opt 0x0013 flag 0x0 len 28
*Apr 21 17:02:32.319: OSPFv3: Rcv LS UPD from 2.2.2.2 on GigabitEthernet0/0 length 76 LSA count 1
*Apr 21 17:02:32.319: OSPFv3: Synchronized with 2.2.2.2 on GigabitEthernet0/0, state FULL
*Apr 21 17:02:32.323: %OSPFv3-5-ADJCHG: Process 1, Nbr 2.2.2.2 on GigabitEthernet0/0 from LOADING to FULL, Loading Done
*Apr 21 17:02:32.823: Insert LSA 0 adv_rtr 1.1.1.1, type 0x2009 in maxage
*Apr 21 17:02:33.835: OSPFv3: service_maxage: Trying to delete MAXAGE LSA
*Apr 21 17:02:33.835: processing 2.2.2.2/5, type 2002
*Apr 21 17:02:33.835: free check failed 0 0 0 0 0 0 1
*Apr 21 17:02:33.835: processing 2.2.2.2/1400, type 2009
*Apr 21 17:02:33.839: free check failed 0 0 0 0 0 0 1
*Apr 21 17:02:33.839: processing 1.1.1.1/0, type 2009
*Apr 21 17:02:33.839: free check failed 0 0 0 0 0 0 1
*Apr 21 17:02:34.503: Insert LSA 0 adv_rtr 2.2.2.2, type 0x2009 in maxage
*Apr 21 17:02:35.379: free check failed 0 0 0 0 0 0 1
*Apr 21 17:02:35.383: Insert LSA 0 adv_rtr 1.1.1.1, type 0x2009 in maxage

 

3.8 Configure, verify, and troubleshoot IPv6 static routing

IPv6 static routing is the same as IPv4 the only difference is the structure of the IP addresses which use prefixes instead of netmasks.

Screenshot_2018-04-21_16-59-57

For example here we create a static route to R3 through R2 and set the Administrative Distance to 1.

Router#conf t 
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#ipv6 route ?
 X:X:X:X::X/<0-128> IPv6 prefix
 vrf IPv6 Routing table

Router(config)#ipv6 route 2001:DB8:0:3::/64 ?
 Async Async interface
 Auto-Template Auto-Template interface
 BVI Bridge-Group Virtual Interface
 CDMA-Ix CDMA Ix interface
 CTunnel CTunnel interface
 Dialer Dialer interface
 Ethernet IEEE 802.3
 GigabitEthernet GigabitEthernet IEEE 802.3z
 Lex Lex interface
 Loopback Loopback interface
 MFR Multilink Frame Relay bundle interface
 Multilink Multilink-group interface
 Null Null interface
 Port-channel Ethernet Channel of interfaces
 SSLVPN-VIF SSLVPN Virtual Interface
 Tunnel Tunnel interface
 Vif PGM Multicast Host interface
 Virtual-PPP Virtual PPP interface
 Virtual-Template Virtual Template interface
 Virtual-TokenRing Virtual TokenRing
 X:X:X:X::X IPv6 address of next-hop
 vmi Virtual Multipoint Interface
 
Router(config)#ipv6 route 2001:DB8:0:3::/64 2001:DB8::C802:17FF:FE35:8 ?
 <1-254> Administrative distance
 multicast Route only usable by multicast
 nexthop-vrf Nexthop IPv6 VRF
 tag Tag value
 unicast Route only usable by unicast
 <cr>

Router(config)#ipv6 route 2001:DB8:0:3::/64 2001:DB8::C802:17FF:FE35:8 1
Router(config)#^Z
Router#traceroute 2001:DB8:0:1:C803:17FF:FE44:8
*Apr 21 17:46:11.835: %SYS-5-CONFIG_I: Configured from console by console

Type escape sequence to abort.
Tracing the route to 2001:DB8:0:1:C803:17FF:FE44:8

1 2001:DB8:0:3:C803:17FF:FE44:1C 28 msec
 2001:DB8::C802:17FF:FE35:8 12 msec
 2001:DB8:0:3:C803:17FF:FE44:1C 12 msec
Router#

 

3.8.a Default route

Router(config)#ipv6 route ::/0 2001:DB8::C802:17FF:FE35:8

3.8.b Network route

Router(config)#ipv6 route 2001:DB8:0:1::/64 2001:DB8::C802:17FF:FE35:

3.8.c Host route

Router(config)#ipv6 route 2001:DB8:0:3:C803:17FF:FE44:1C/128 2001:DB8::C802:17FF:FE35:8

3.8.d Floating static

Router(config)#ipv6 route 2001:DB8:0:1::/64 2001:DB8::C802:17FF:FE35:8 254

 

IPv6 Routing Table - Default - 8 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
 B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
 I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
 D - EIGRP, EX - EIGRP external
 O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
 ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
S ::/0 [1/0]
 via 2001:DB8::C802:17FF:FE35:8
C 2001:DB8::/64 [0/0]
 via GigabitEthernet0/0, directly connected
L 2001:DB8::C801:17FF:FE26:8/128 [0/0]
 via GigabitEthernet0/0, receive
D 2001:DB8:0:1::/64 [90/3072]
 via FE80::C802:17FF:FE35:8, GigabitEthernet0/0
 via FE80::C803:17FF:FE44:1C, GigabitEthernet1/0
C 2001:DB8:0:3::/64 [0/0]
 via GigabitEthernet1/0, directly connected
L 2001:DB8:0:3:C801:17FF:FE26:1C/128 [0/0]
 via GigabitEthernet1/0, receive
S 2001:DB8:0:3:C803:17FF:FE44:1C/128 [1/0]
 via 2001:DB8::C802:17FF:FE35:8
L FF00::/8 [0/0]
 via Null0, receive
Router#

3.9 Configure, verify, and troubleshoot single area and multi-area OSPFv2 for IPv4 (excluding authentication, filtering, manual summarization, redistribution, stub, virtual-link, and LSAs)

Screenshot_2018-04-08_16-08-30.png

The default area in ospf is Area 0, it is also referred to as the backbone. To configure a subnet to be in a area simple change the number at the end of the network command.

Here is the config for R1:

interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 duplex half
!
!
interface GigabitEthernet4/0
 ip address 10.0.0.1 255.255.255.0
 negotiation auto
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.0.0.255 area 0
 network 192.168.1.0 0.0.0.255 area 1
!

R2:

interface GigabitEthernet4/0
 ip address 10.0.1.2 255.255.255.0
 negotiation auto
!
interface GigabitEthernet5/0
 ip address 10.0.0.2 255.255.255.0
 negotiation auto
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.0.0.255 area 0
 network 10.0.1.0 0.0.0.255 area 0
!

R3:

interface FastEthernet0/0
 ip address 192.168.2.1 255.255.255.0
 duplex half
!
interface GigabitEthernet4/0
 ip address 10.0.1.3 255.255.255.0
 negotiation auto
!
router ospf 1
 log-adjacency-changes
 network 10.0.1.0 0.0.0.255 area 0
 network 192.168.2.0 0.0.0.255 area 2
!

Routers that border the area 0 and other areas are called “ABRs” Area-Border-Routers:

R2#show ip ospf border-routers

OSPF Process 1 internal Routing Table

Codes: i - Intra-area route, I - Inter-area route

i 192.168.1.1 [1] via 10.0.0.1, GigabitEthernet5/0, ABR, Area 0, SPF 6
i 192.168.2.1 [1] via 10.0.1.3, GigabitEthernet4/0, ABR, Area 0, SPF 6

To verify OSPF operation:

R2#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
192.168.2.1 1 FULL/BDR 00:00:37 10.0.1.3 GigabitEthernet4/0
192.168.1.1 1 FULL/BDR 00:00:34 10.0.0.1 GigabitEthernet5/0
R2#show ip osp
R2#show ip ospf 
R2#show ip ospf 
R2#show ip ospf ?
 <1-65535> Process ID number
 border-routers Border and Boundary Router Information
 database Database summary
 flood-list Link state flood list
 interface Interface information
 max-metric Max-metric origination information
 mpls MPLS related information
 neighbor Neighbor list
 request-list Link state request list
 retransmission-list Link state retransmission list
 rib Routing Information Base (RIB)
 sham-links Sham link information
 statistics Various OSPF Statistics
 summary-address Summary-address redistribution Information
 timers OSPF timers information
 traffic Traffic related statistics
 virtual-links Virtual link information
 | Output modifiers
 

R2#show ip ospf data
R2#show ip ospf database

OSPF Router with ID (10.0.1.2) (Process ID 1)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
10.0.1.2 10.0.1.2 1597 0x80000004 0x004A89 2
192.168.1.1 192.168.1.1 1928 0x80000002 0x00E35F 1
192.168.2.1 192.168.2.1 1588 0x80000003 0x00023A 1

Net Link States (Area 0)

Link ID ADV Router Age Seq# Checksum
10.0.0.2 10.0.1.2 30 0x80000002 0x00485F
10.0.1.2 10.0.1.2 1597 0x80000001 0x004C5A

Summary Net Link States (Area 0)

Link ID ADV Router Age Seq# Checksum
192.168.1.0 192.168.1.1 1936 0x80000001 0x00BDA8
192.168.2.0 192.168.2.1 1584 0x80000001 0x00ABB8

To troubleshoot problems with neighbors use the debug commands:

R2#debug ip ospf ?
 adj OSPF adjacency events
 capability OSPF Capability
 database-timer OSPF database timer
 events OSPF events
 flood OSPF flooding
 hello OSPF hello events
 lsa-generation OSPF lsa generation
 mpls OSPF MPLS
 nsf OSPF non-stop forwarding events
 packet OSPF packets
 retransmission OSPF retransmission events
 rib OSPF RIB
 spf OSPF spf
 tree OSPF database tree
R2#debug ip ospf events
 OSPF events debugging is on
 *Apr 8 16:19:10.175: OSPF: Send hello to 224.0.0.5 area 0 on GigabitEthernet5/0 from 10.0.0.2
 *Apr 8 16:19:12.091: OSPF: Send hello to 224.0.0.5 area 0 on GigabitEthernet4/0 from 10.0.1.2
 *Apr 8 16:19:13.171: OSPF: Rcv hello from 192.168.1.1 area 0 from GigabitEthernet5/0 10.0.0.1
 *Apr 8 16:19:13.171: OSPF: End of hello processing
 *Apr 8 16:19:16.371: OSPF: Rcv hello from 192.168.2.1 area 0 from GigabitEthernet4/0 10.0.1.3
 *Apr 8 16:19:16.371: OSPF: End of hello processing
 *Apr 8 16:19:19.419: OSPF: Send hello to 224.0.0.5 area 0 on GigabitEthernet5/0 from 10.0.0.2
 *Apr 8 16:19:21.219: OSPF: Send hello to 224.0.0.5 area 0 on GigabitEthernet4/0 from 10.0.1.2
 *Apr 8 16:19:22.211: OSPF: Rcv hello from 192.168.1.1 area 0 from GigabitEthernet5/0 10.0.0.1
 *Apr 8 16:19:22.211: OSPF: End of hello processing

 R2#debug ip ospf adj
*Apr 8 16:28:35.631: OSPF: Interface GigabitEthernet5/0 going Up
*Apr 8 16:28:35.651: OSPF: 2 Way Communication to 192.168.1.1 on GigabitEthernet5/0, state 2WAY
*Apr 8 16:28:35.651: OSPF: Backup seen Event before WAIT timer on GigabitEthernet5/0
*Apr 8 16:28:35.655: OSPF: DR/BDR election on GigabitEthernet5/0 
*Apr 8 16:28:35.655: OSPF: Elect BDR 10.0.1.2
*Apr 8 16:28:35.655: OSPF: Elect DR 192.168.1.1
*Apr 8 16:28:35.655: OSPF: Elect BDR 10.0.1.2
*Apr 8 16:28:35.655: OSPF: Elect DR 192.168.1.1
*Apr 8 16:28:35.659: DR: 192.168.1.1 (Id) BDR: 10.0.1.2 (Id)
*Apr 8 16:28:35.659: OSPF: GigabitEthernet5/0 Nbr 192.168.1.1: Prepare dbase exchange
R2(config-if)#^Z
R2#
*Apr 8 16:28:35.659: OSPF: Send DBD to 192.168.1.1 on GigabitEthernet5/0 seq 0xA5D opt 0x52 flag 0x7 len 32
*Apr 8 16:28:35.971: %SYS-5-CONFIG_I: Configured from console by console
R2#
*Apr 8 16:28:36.135: OSPF: Build router LSA for area 0, router ID 10.0.1.2, seq 0x80000007, process 1
R2#
*Apr 8 16:28:37.607: %LINK-3-UPDOWN: Interface GigabitEthernet5/0, changed state to up
*Apr 8 16:28:38.607: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet5/0, changed state to up
R2#
*Apr 8 16:28:40.295: OSPF: Send DBD to 192.168.1.1 on GigabitEthernet5/0 seq 0xA5D opt 0x52 flag 0x7 len 32
*Apr 8 16:28:40.295: OSPF: Retransmitting DBD to 192.168.1.1 on GigabitEthernet5/0 [1]
*Apr 8 16:28:40.315: OSPF: Rcv DBD from 192.168.1.1 on GigabitEthernet5/0 seq 0x512 opt 0x52 flag 0x7 len 32 mtu 1500 state EXSTART
*Apr 8 16:28:40.319: OSPF: NBR Negotiation Done. We are the SLAVE
*Apr 8 16:28:40.319: OSPF: GigabitEthernet5/0 Nbr 192.168.1.1: Summary list built, size 6
*Apr 8 16:28:40.319: OSPF: Send DBD to 192.168.1.1 on GigabitEthernet5/0 seq 0x512 opt 0x52 flag 0x2 len 152
*Apr 8 16:28:40.335: OSPF: Rcv DBD from 192.168.1.1 on GigabitEthernet5/0 seq 0x513 opt 0x52 flag 0x1 len 172 mtu 1500 state EXCHANGE
*Apr 8 16:28:40.339: OSPF: Exchange Done with 192.168.1.1 on GigabitEthernet5/0
*Apr 8 16:28:40.339: OSPF: Send LS REQ to 192.168.1.1 length 24 LSA count 2
*Apr 8 16:28:40.339: OSPF: Send DBD to 192.168.1.1 on GigabitEthernet5/0 seq 0x513 opt 0x52 fl
R2#ag 0x0 len 32
*Apr 8 16:28:40.355: OSPF: Rcv LS UPD from 192.168.1.1 on GigabitEthernet5/0 length 96 LSA count 2
*Apr 8 16:28:40.363: OSPF: We are not DR to build Net Lsa for interface GigabitEthernet5/0
*Apr 8 16:28:40.363: OSPF: Build network LSA for GigabitEthernet5/0, router ID 10.0.1.2
*Apr 8 16:28:40.363: OSPF: Build network LSA for GigabitEthernet5/0, router ID 10.0.1.2
*Apr 8 16:28:40.363: OSPF: Synchronized with 192.168.1.1 on GigabitEthernet5/0, state FULL
*Apr 8 16:28:40.363: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.1.1 on GigabitEthernet5/0 from LOADING to FULL, Loading Done
*Apr 8 16:28:40.363: OSPF: Rcv LS REQ from 192.168.1.1 on GigabitEthernet5/0 length 36 LSA count 1
*Apr 8 16:28:41.139: OSPF: Build router LSA for area 0, router ID 10.0.1.2, seq 0x80000008, process 1
R2#
*Apr 8 16:28:41.859: OSPF: Neighbor change Event on interface GigabitEthernet5/0
*Apr 8 16:28:41.859: OSPF: DR/BDR election on GigabitEthernet5/0 
*Apr 8 16:28:41.863: OSPF: Elect BDR 10.0.1.2
*Apr 8 16:28:41.863: OSPF: Elect DR 192.168.1.1
*Apr 8 16:28:41.863: DR: 192.168.1.1 (Id) BDR: 10.0.1.2 (Id)
R2#no debug ip ospf adj 
OSPF adjacency events debugging is off
R2#

To see is OSPF is functioning properly look at the routing table:

R2#show ip route
 Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 2 subnets
 C 10.0.0.0 is directly connected, GigabitEthernet5/0
 C 10.0.1.0 is directly connected, GigabitEthernet4/0
 O IA 192.168.1.0/24 [110/2] via 10.0.0.1, 00:33:40, GigabitEthernet5/0
 O IA 192.168.2.0/24 [110/2] via 10.0.1.3, 00:28:05, GigabitEthernet4/0

Missing routes indicate either a neighbor relationship failure or missing “network” commands on routers. Note that the routes to 192.168.1.0/24 and 192.168.2.0/24 are marked as IA (inter-area) routes.

3.8 Configure, verify, and troubleshoot IPv4 and IPv6 static routing

This will be two parts. I will do the IPV4 part first.

Here is the topology used:

Screenshot_2018-04-02_18-09-33.png

3.8.a Default route

In order to get PC1 to be able to ping PC2 R1 needs to have a route to PC2’s subnet. This can be achieved using the default route:

R1(config)#ip route 0.0.0.0 0.0.0.0 172.16.0.2
R1(config)#^Z
R1#
*Apr 2 18:10:42.475: %SYS-5-CONFIG_I: Configured from console by console
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route

Gateway of last resort is 172.16.0.2 to network 0.0.0.0


172.16.0.0/24 is subnetted, 1 subnets
C 172.16.0.0 is directly connected, GigabitEthernet4/0
 10.0.0.0/24 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, FastEthernet0/0
S* 0.0.0.0/0 [1/0] via 172.16.0.2
R1#

If R2 is configured the same PC1 will be able to ping PC2. PC1 and PC2 will also need a default route or gateway in the same subnet as their interface:

PC1> ip 10.0.0.2/24 10.0.0.1
Checking for duplicate address...
PC1 : 10.0.0.2 255.255.255.0 gateway 10.0.0.1

This configuration is not suitable for larger networks.

3.8.b Network router

We could configure router R1 and R2 to access each other with a static network route:

R1(config)#ip route 10.0.1.0 255.255.255.0 172.16.0.2

R2(config)#ip route 10.0.0.0 255.255.255.0 172.16.0.1

R2#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 1 subnets
C 172.16.0.0 is directly connected, GigabitEthernet4/0
 10.0.0.0/24 is subnetted, 2 subnets
S 10.0.0.0 [1/0] via 172.16.0.1
C 10.0.1.0 is directly connected, FastEthernet0/0
R2#

3.8.c Host route

We can also configure this route using a host route

R1(config)#ip route 10.0.1.1 255.255.255.255 172.16.0.2 

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 1 subnets
C 172.16.0.0 is directly connected, GigabitEthernet4/0
 10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
S 10.0.1.1/32 [1/0] via 172.16.0.2
C 10.0.0.0/24 is directly connected, FastEthernet0/0
R1#

3.8.d Floating static

A route can be configured with a very high administrate distance (like 254):

R1(config)#ip route 10.0.1.0 255.255.255.0 172.16.0.2 254
R1(config)#^Z
R1#show i
*Apr 2 18:26:10.139: %SYS-5-CONFIG_I: Configured from console by console
R1#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 1 subnets
C 172.16.0.0 is directly connected, GigabitEthernet4/0
 10.0.0.0/24 is subnetted, 2 subnets
C 10.0.0.0 is directly connected, FastEthernet0/0
S 10.0.1.0 [254/0] via 172.16.0.2
R1#

This way if all other routes with a lower administrative distance this backup route will be used.

 

3.7 Compare and contrast interior and exterior routing protocols

Interior and exterior routing protocol differ in how they route. Interior routing protocol are designed to be using inside and AS (Autonomous System) while Exterior routing protocols are designed to be used between AS.

Here is the definition from the Exam Guide:

IGP: A routing protocol that was designed and intended for use inside a single autonomous system (AS)

EGP: A routing protocol that was designed and intended for use between different autonomous systems

There is only one EGP (BGP) but many IGPs.

3.6 Compare and contrast distance vector and link state routing protocols

Distance Vector

DV routing protocols calculate a route’s metric based on the number of hops, this has the disadvantage that a route that is slower may be chosen because it has less hops:

Screenshot_2018-04-02_17-07-59.png

If a distance vector routing protocol such as RIP was running on the above topology it would choose the one with the least hops. In this case the route IOU1=>IOU2=>IOU3 is actually slower than the higher hop count route IOU1=>IOU4=>IOU5=>IOU3.

In order to prevent routing loops distance vector protocols have a split horizon. This means they only share routes on one side of the horizon to the other.

Here is an excerp from the Official CCNA 200-125 Exam guide:

Screenshot_2018-04-02_17-13-01

Distance vector protocols poison dead routes by using an infinite metric.

Link-State Routing Protocols

LS routing protocols create a virtual map of all of the links in a network and choose routes based on the highest bandwidth. The most popular link-state routing protocol is OSPF which implements the Dijkstra algorithm to calculate be best path in a network for each route.

If a link-state routing protocol was running in the above topology it would have chose the best route based on total speed not the amount of hops.

In order to create a topology OSPF creates a LSDB that contains all the information about all the links in that network, OSPF will then use a LSA (link state advertisement) to advertise this with it’s neighbors. LSU (Link state updates) are used to exchange information with neighbors until each neighbor has a full map of the entire topology.

This process is CPU intensive and means the LS routing protocols have a higher overhead than DV protocols.